Executive Summary

This application note outlines a process through which printed circuit boards (PCBs) may be produced using the PCB design and fabrication tools available in the Electrical and Computer Engineering Department at Michigan State University. This document describes the PCB production process in general and also presents a case study.

Table of Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Overview</td>
<td>2</td>
</tr>
<tr>
<td>2. Prototyping</td>
<td>3</td>
</tr>
<tr>
<td>3. Schematic Capture</td>
<td>3</td>
</tr>
<tr>
<td>4. Physical Layout</td>
<td>4</td>
</tr>
<tr>
<td>5. Physical Creation of PCB</td>
<td>7</td>
</tr>
<tr>
<td>6. Lessons Learned and Recommendations</td>
<td>7</td>
</tr>
<tr>
<td>7. Appendix</td>
<td>8</td>
</tr>
</tbody>
</table>
1. Overview

There are several basic steps involved in producing a printed circuit board (PCB). Most designs begin with a hand drawn schematic and design plan. With these, the circuit is prototyped and tested to verify that the design works correctly. Then, using software, an electronic version of the schematic is created. A netlist file is created from the electronic schematic and used in other software to create the physical layout of the PCB. Next, the components are placed and routed in the physical layout software and Gerber files are created. These Gerber files are used in a prototyping system to mill, drill, and cut the PCB substrate. The components are then placed and soldered to the substrate. Finally, the board is tested to verify that it works as expected.

The major steps in the PCB design and fabrication process are as follows:

1. design and test the prototype circuit—by hand;
2. capture the circuit’s schematic—using OrCAD Capture or similar software;
3. perform the physical layout of the circuit—using OrCAD Layout or similar software;
4. fabricate, populate and test the PCB—done by ECE shop personnel or similar personnel.

With this general procedural framework in mind, read on to learn more about each step in this process (see Fig. 1).

Fig 1: PCB design flow.
2. Prototyping

With a basic idea in mind, a circuit schematic is developed and analyzed to ensure the desired functionality and performance. When creating a circuit for PCB production, a designer would also select specific components at this time. Commonly, the next step is to prototype and to test the circuit. It is also possible to use the schematic capture software along with related software to simulate the circuit without building it on a prototyping board.

In the case of the example optosensor circuit (see Fig. 2), a rough sketched schematic was initially created, along with some design specifications. The necessary components were chosen and the circuit was built on a prototyping board to verify that it met the design criteria. During the prototype board layout phase, thought was given to the best way to arrange the components for the final PCB layout. As a result, the PCB layout is very similar to the protoboard layout you see in Fig 2.

Fig 2: The optosensor circuit: (a) hand-drawn schematic and (b) prototyped circuit.

3. Schematic Capture

Schematic capture software comes in several forms. In this application note, OrCAD Capture v9.10 will be used. Schematic capture allows the PCB designer to create an electronic schematic. This electronic schematic contains more information than its paper relatives. For example, every part symbol in Capture contains information telling what footprint the symbol is associated with. (Footprints are the symbols used in layout software to define the physical design of each component.)

Capture parts symbols are used in a symbolic manner. Thus, the part symbol on Capture’s screen does not show what the actual physical component looks like. It does allow the designer to connect all the components in a circuit and to test the workings of the circuit by exporting files to other software. For our purpose, Capture provides the starting point for creating a physical layout in layout software.

A good way to begin learning Capture is through the Capture menu item Help à Learning Capture. This tutorial will do a good job of explaining the basics of Capture. For further help, look in the troubleshooting section found in the appendix of this document and search for your question under Help à Help Topics on Capture’s menu bar. In the following section of this application note, we will assume the reader has a basic familiarity with Capture.
Capture was used to create an electronic schematic of the optosensor circuit. First, the existing part libraries were searched for the necessary parts. A part symbol is needed for every component that will need to be drilled or routed in Layout. This means that a part symbol will be needed for things such as power connections. In this particular case, the optosensor circuit required a power connector that was not available in the Capture libraries. Thus, one was created using the process demonstrated in the Learning Capture tutorial. These part symbols were placed on the drawing area and wired together as they had been wired in the paper schematic and on the prototype board.

Once the optosensor circuit schematic was completed a netlist file was created for use in the physical layout software. This was done from the Project manager screen in Capture by selecting the name of the design, which in this case was “\optoencoder.dsn”. With this item highlighted, the menu item Tools→Create Netlist… was selected. In the displayed Create Netlist dialog box, the “Layout” tab along the top of the dialog box was selected. Here the netlist file name and location were specified and then created with the click of an OK. The netlist file in this case was called “optoencoder.mnl”. This file contained all the information necessary to begin the physical layout of the optosensor circuit.

One important comment is that every part symbol used in Capture must have a footprint associated with it. The footprint property of the symbol may be edited by double clicking on the part symbol in the schematic and editing the footprint property on the parameter list.

4. Physical Layout

A blueprint of a house tells the size of lumber to use, as well as the dimensions of the living room wall and the dimensions of the window cut into it. It gives all the physical information necessary to build the house. Physical layout software can be thought of as a “blueprint” for a PCB.

There are several programs available for doing physical layout. In this application note, we will use v9.10.

The basic building blocks used in Layout are footprints. A footprint contains all the physical dimensions related to a particular part. For example, a 14-pin dip footprint defines where each of the 14 drill holes are to be located, as well as associated information, such as text defining the part number of the component.

In Layout the footprints of the various parts are placed and then routed. Routing refers to defining where the copper interconnects in the circuit will be located. Interconnects are copper paths on the surface of the PCB that connect one pin to another. Interconnects are also known as “routes” or “traces”.

In a house blueprint one has a rough frame blueprint and an exterior view blueprint that contain different information about the same part of the house. In much the same way, Layout uses different layers to contain all of the information about the PCB. Some of the layers that will be used in doing two sided PCBs are TOP, BOT, and SST. The TOP layer contains information pertaining to the top of your PCB, such as traces (routes) that are drawn on the top. The BOT layer contains information pertaining to the bottom of your PCB, such as traces that are drawn on the bottom. The SST layer is the “Silk Screen Top” layer, and contains the text that will appear on the top of the PCB. There are many other layers as well, some of which will never be used in two sided PCBs. All of the layers may be accessed through View→Select Layer…, or by choosing the layer from the pull down menu on the top of the main screen. To change the color
settings of a layer, or to make it invisible, choose Options→Colors…. and edit the layer of interest.

In working with layout, a variety of tools will be used. Depending on the tool currently activated, the cursor will perform very different actions. All of these tools may be selected from the menu bar at the top of the screen. For example the large T symbol on the toolbar is the text tool. This allows text to be added and edited. The obstacle tool allows the drawing and editing of obstacles such as the board outline, and outlines for parts. The connection tool allows the editing of pin connections. (Note: if the design is done correctly in Capture, the connection tool will not be used, as all of the connections will be defined from the Capture netlist.) The Shove Track Mode, Edit Segment Mode, and Add/Edit Route Mode tools are used when adding or editing routes.

A good way to begin learning Layout is through the Layout menu item Help→Learning Layout. This tutorial will do a decent job of explaining the basics of Layout. For further help, look in the troubleshooting section found in the appendix of this document and search for your question under Help→Help Topics on Layout’s menu bar. In the following section of this application note, we will assume the reader has a basic familiarity with Layout.

The first task when starting most physical layouts is to create all the necessary footprints that are not already available in the default libraries. For instructions on creating new footprints, please refer to application note titled – “How to Create Footprints in OrCAD Layout”.

The physical layout of the optosensor circuit was begun by creating all the necessary footprints not available in the existing libraries. Then, in Layout, File→New was chosen. The default template file was used and the optosensor netlist file was selected. Finishing the process left a screen with many footprints connected by yellow lines. The yellow lines showed the connections between pins. These connections were defined when the optosensor schematic was created in Capture.

Next the board outline was drawn. With the obstacle tool selected, a rectangle of the correct size was drawn. To specify the obstacle as a board outline, its properties were edited by double clicking on the outline. On the properties table that appeared, the Obstacle Type was set to “Board Outline” and Obstacle Layer was set to “Global Layer”.

Once the board outline was drawn, the components were placed and oriented. To move and edit components the component tool was used. All the components were placed inside the board outline. In the case of the optosensor circuit, the sensors were placed on the left side of the board and the output BNC’s and power supply were placed on the other end with circuitry in between.

At this time, text and necessary extra drill holes may be added to the board. On the optosensor circuit, a drilled hole of 1/8” was placed at each corner of the board for mounting purposes. These drill holes were implemented by creating a footprint that had one pin consisting of a drill of 1/8”. The first drill hole was placed on the screen by right clicked in the background and select New… defining a new component using the newly defined footprint. This process was repeated three more times to give a drill hole in each corner of the board. Text identifying the board and important points on the board were added at this time. When placing text on the PCB the text must NOT overlap any traces or drill holes as the ECE Shop equipment realizes text through the use of copper and thus overlapping text and traces will lead to open and short circuits.

Once all of the components and drill holes and such are in place on the board, the next step is to route the traces. It is a good practice to route as many traces as possible on the bottom
of the board, and connect a route to a component pin from the bottom side of the board. This allows for easy soldering of the parts to the board.

Each of the yellow lines connecting pins on components needs to be “routed”. What this means is that the actual path of the copper across the surface of the board must be defined. On a prototyping board, one may “route” a wire over another wire or component to get to its connecting pin. However, because the surface of the PCB is 2 dimensional, one can not have one route cross another. If two routes were to touch, they would become shorted together. Thus, routing requires some thought and “art” in order to route all the wires where they must go without crossing each other. When it is impossible to route two traces without crossing, a via is used. A via is basically a drilled hole in the PCB that allows the copper to cross to the top side of the board, run over a ways, and then cross back to the bottom through another via.

Each Route has a certain physical width. The default setting is 12. With the ECE shop equipment, we would like to use a larger size such as 24. To change the width setting select View -> Database Spreadsheets… -> Nets. On this screen select all the nets and change their widths’ to 24.

With the “Add/Edit Route Mode” tool selected, new traces may be routed by clicking on the yellow line near the starting pin. From this point, the routing is very similar to adding nets in Capture. If a via is needed, right click with a route selected and choose “add via”. Draw a route to the via on the bottom, then change layers to the top and route it on the top from the via over to another via that will place you beyond the route you want to cross. Then route from that via on the bottom of the board.

Vias are defined by a padstack in the same way a pin on a footprint is defined. The default via is incorrect for use with the ECE shop equipment. To change the via padstack properties, select View -> Database Spreadsheets… -> Padstacks. On this screen select “Via1” and changes its settings so that the TOP and BOT layer are round and of size 95, and the Drill layers are round and of size 40.

Once the routing is complete, the board layout is finished. All that remains is to double-check that no text overlaps routes and make sure there are no loose ends anywhere on the board. Once the board has been reviewed and is completed, the final step is to create the Gerber files.

A Gerber file is a file that contains the information from Layout that is necessary for the prototyping machine to drill, mill, and cut the PCB. A Gerber file is created for every layer of interest. For example, a TOP Gerber file defines how to drill, mill, and cut the top of the board. To create the Gerber files, select the menu item Options -> Post Process Settings… By default Layout is set up to make Gerber files for many layers. For our process we are interested in five Gerber files:

1. Top layer (TOP)
2. Bottom layer (BOT)
3. Silk Screen Top layer (SST)
4. Drill layer (DRD)
5. Board outline layer. (?)

For the Board outline layer, we want a Gerber file of a layer containing the board outline and nothing else. By default the Board outline is on the Global layer along with some other
items. The solution developed for the optosensor circuit was to double click on the board outline and change its location to the GND layer. All the other footprint were also checked to verify that the board outline was the only item on the GND layer. Then a Gerber file of the GND layer was created for use as the Board outline.

All of the post processing entries except the five used may be erased. By default the Device used is “Gerber RS 274-D”. For the ECE Shop uses “Extended Gerber” is the proper device. The device entry of all the layers should be changed to “Extended Gerber” by double clicking on an entry and editing its properties. The filename may also be edited using the properties window. For ECE Shop use, a descriptive name should be used for each Gerber file with gbr as the three-letter extension to the file. For example the Gerber file for the TOP of the board might be called test_cir_top.gbr. You may preview the Gerber file for a particular layer by right clicking on that layer’s entree and selecting “Preview”. To create the files once all of the settings are correct, right click on the entrees and select “Run Batch”. This will create all of the Gerber files that were specified and place them in the same directory as the layout file. It will also create several other files, which for our purposes, may be ignored.

5. Physical Creation of PCB

Now all the Gerber files necessary to physically create the PCB are available. These Gerber files are used along with the prototyping machine to create the PCB substrate. The components are then added and soldered into place, completing the PCB.

In the case of the optosensor circuit, the Gerber files were emailed to the ECE Shop, along with a schematic and parts list for the PCB. In the ECE shop, those files were used along with a prototyping system called Quick Circuit 7000 to create the PCB substrate. Then, referencing a copy of the optosensor Layout, the components were placed and soldered, completing the PCB.

Using the current ECE shop equipment, the maximum board size is 13”x19”. During normal workload periods, it will take 2 days from when the Gerber files are sent to the ECE Shop and when a completed PCB is returned.

When the board is returned it needs to be verified. First, one should visually inspect all connections for solder bridges and bad connections. Then, with the PCB still unpowered, one should use an ohmmeter to verify the correct pin connections through the traces. If all seems well, then power may be applied with testing and troubleshooting to follow as necessary. All repairs to the board should be conducted by an ECE Shop staff member only, as it is very easy to damage the PCB when soldering or conducting other repairs.

6. Lessons Learned and Recommendations

While working on the optosensor project, I learned some things that others might find useful. These are summarized below.

1. It is important to route all possible traces on the bottom of the board. This allows components to sit tight on the surface of the PCB.
2. The larger you can make the copper padstack on top and bottom, the better, as this allows easy soldering. A size of 95 for a drill hole of 40 works well.

3. All PCB repairs such as soldering should be done by an ECE Shop staff member.

4. Finally, I learned that producing PCB’s isn’t all that hard, except for the little things that hold you up. For that reason, I recommend that users provide feedback and continue to improve this document by adding those little things that I haven’t mentioned here.

7. Appendix

This appendix defines some common PCB terminology, provides solutions to some common problems and lists additional sources of information.

Frequently Asked Questions

How much does all this cost?
- Well, the software is available to MSU students with computer accounts in the Computer Engineering Computer Labs. The other answer is that the OrCAD Software cost about $3,500 and the Prototyping system cost about $10,000.

How large of a PCB can be made using the ECE Shop equipment?
- 13” x 19”

What is a padstack?
- A padstack is a collection of information defining how a pin connects to the PCB. This padstack includes information about every layer in the board. For example, a dip chip would have a padstack defined for its pins. This padstack would define the size of the copper area around the pin on the top and the bottom of the PCB. It would also define the size of the hole to be drilled through the board. (Note: for more information on padstacks, refer to application note an_pcb_2 – “How to Create Footprints in OrCAD Layout”.)

What is a footprint?
- A footprint is a collection of information defining how a part or component will attach and be used on the PCB. For example, a dip chip footprint would define were each of its pin holes are to be drilled relative to each other.

What is a pin?
- Pin has several meanings. When I say pin, I generally mean “any connection on the PCB that may serve as a termination point for a route”.

What is a Gerber file?
- A Gerber file is a file that contains the information from Layout necessary for the prototyping machine to drill, mill, and cut the PCB. You have a Gerber file for each Layer of information about the board. For example, you have a TOP Gerber file, which defines how to mill, drill, and cut the top of the board.
What is a layer?
- Lets say you take several sheets of clear plastic and write on it. If you overlay these piece of plastic, they look like one piece that contains all the information. And yet each one only holds a part of the total writing. In the same way layout uses layers of information. In some cases the layer correspond to a physically different space such as the TOP and BOT layer and in other cases, the layers may just contain different information about the same physical space such as TOP and SST.

Troubleshooting

I edited my part symbol in Capture, but when I open my design that uses the part symbol, it is still using the old version of the part symbol.

Capture stores the original version of your part symbol in the library you specify. When you use that part symbol in Capture, a copy is made of the original part symbol. This copy is stored in the Design Cache of your project. Thus you have edited the original, but the copy used in your schematic is still a copy of the old symbol. To updated the design cache to the new version do the following.

In Capture’s project manager window select your part symbol from the Design Cache folder. Select the menu item Design → Update Cache. Now when you reenter your design schematic, you should see the updated symbol.

I edited my footprint in Layout, but when I close the Library Manager and return to the layout, it is still using the old version of the footprint

Layout stores the original version of your footprint in the library you specify. When you use that footprint in Layout, a copy is made of the original footprint. This copy is stored under in the “Local” library. Thus you have edited the original, but the currently used footprint is still a copy of the old footprint. There are likely several ways to update footprints. One way I know is as follows.

With the component tool select, double click on the component with the footprint of interest. On the properties screen that arises click on the “Footprint…” button. Direct it to the original copy and select OK.

Additional Sources for Information

OrCAD menu item Help → Help Topics...

OrCAD Homepage : “http://www.OrCAD.com/”
Aspect Online : “http://OrCAD.aspectonline.com/”