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Introduction 

This document answers/solutions to common questions/problems encountered using the Cadence 
EDA tools. 

Troubleshooting Guide: Frequently Asked Questions 

General 
  
My icfb window is frozen. How do I close it?   
 
Open an Xterm window and type ps -u username and note the PID for icfb.exe. Execute the command kill -9 
PIDno. This will close the cadence session. Delete the lock files if you have any.  
 
How do I open the locked file in edit mode?  
 
Go the folder in which your design files are stored.  Depending on the number of views your design has, you 
will have folders named schematic, symbol etc. Go to the folder schematic. You might see the files master.tag  
pc.db  prop.xx  sch.cd%  sch.cd- sch.cdb sch.cdb.cdslck etc. Leave the files master.tag  pc.db  prop.xx sch.cdb 
and delete the other files (using rm filename). After this process you should be able to open the file in edit mode. 
While doing this you should not have any other cadence session accessing the particular file in edit mode (for 
example you might be accessing the file from home using Xwin). 
 
How do I capture images for my lab report? 
 
Refer to the Guide to Capturing Images.  
 

Library Manager 
 
Why can’t I see the default parts libraries in the manager? 
 
When you first start Cadence, it creates a new library definition file called “cds.lib” in the directory you 
launched it from. This links the necessary parts libraries to the Cadence workspace.  If the file exists in the 
launch directory but you aren’t seeing the parts libraries, check to make sure that the following line is in 
“cds.lib”: 
 
INCLUDE /opt/cds/local/cdssetup/cds.lib 
 
If necessary, add this statement to the “cds.lib” using the text editor of your choice.  To avoid having this 
problem in the future, always launch Cadence from your class directory, and try not to edit, move or delete the 
file unless you need to. 
 
Why can’t I see any of my own design libraries in the manager? 
 
Most likely, you have launched Cadence from a directory that does not contain all of your previous work. A 
common mistake is to run icfb from your home directory (“/home/<username>/cadence”) and not your class 
Cadence directory. Make sure you are running icfb from the correct place. 
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Another possibility is that you have copied your design directories to/from another location and the “cds.lib” 
file that defines the paths to these libraries no longer points to the correct files (or the file is deleted/missing).  
You will have to manually fix “cds.lib” file by going to Edit->Library Path and enter the library and directory 
names by hand. 
 

Schematic Entry 
 
Why do I get a message "Schematic can't be edited. Do you want to open in Read mode?" 
 
Whenever Cadence opens a schematic, it creates a lock file. When you exit the Cadence properly by File -> 
Exit in the Command Interpreter Window, the lock file will be deleted and you will not have any problems in 
opening the file in edit mode. If by any chance the session is closed abruptly, the lock files will be in your 
directory which protects the file to be opened in edit mode. 
 
Why is there a yellow X “warning” in open area of my schematic after I do a check? 
 
It is likely that you have changed the name of a pin in your schematic after having already designed the symbol 
for it. You will need to change the name of the pin in either the schematic or symbol so that the two match. 
 
Why am I getting a warning for some of the wire crossover points in my circuit after I do a check? 

 
By default, Cadence flags the intersection of four wires at a solder dot as a warning.  As long as you are 
confident that the wire connections are appropriate, then you may ignore these warnings. 
 

Symbolic Entry 
 

How do I draw the red selection box around my symbol? 
 
Click the “Selection Box” button in the left-hand toolbar of the Symbol Editing window. On the window that 
pops up, click “Automatic”. This will draw a selection box that bounds the entire symbol within a rectangular 
selection box. 

 
Layout 
 

My layout is getting bigger and it has some DRC errors, but I couldn't locate them. Is there an easy way 
to do it?  
 
In the layout editor window go to Verify->Markers->Find. In the form, check the option Zoom to markers and 
click apply. It will zoom in to all the DRC errors.   
 
How do I remove the DRC errors markings in my layout, so that I can edit the layout without any dirty 
white lines?  
 
In the layout editor window, go to Verify->Markers->Delete All and say ok to the window that is popping up. 
This removes all the DRC error markings.  
 
When I instantiate my inverter, I can only see a box with the cellname of the inverter. Why is this 
happening? 
  
This has to do with hierarchical view of the design. When you do the design the topmost cellview (current 
cellview), it is assigned the number 0 and the other instantiated components are assigned a level above in the 
hierarchy. The default viewing option is to view the components at a hierarchical level of 0. You can change 
this by going to Options->Display in the Layout Editor menu and changing the display levels from 0 to 20 (or 
suitable value of your choice). 
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How do I get the pin names to appear in the layout view? 
 
From the menu, select Options->Display. Under display controls, click the box named “Pin Names” on and 
then click “Apply”. 
 
I tried to open a layout and it seems to be invisible. Why can’t I see it? 
 
It is possible that no technology library is attached to the cell and that no valid layers are defined (confirm by 
looking at the LSW window). Attach a tech library to the library where the cell is located by opening the 
Library manager, right click on the library name, select “Attach Tech Library”, and select the appropriate tech 
library from the drop-down menu (“AMI 0.60u C5N”  for ECE410) 
 

Extracted View 
 

How do I see the parasitic capacitors in the extracted view?  
 
The default setup doesn't extract the parasitic capacitance in the layout. You have to run the command 
“NCSU_parasiticCapIgnoreThreshold=1e-18” in the command interpreter window before extracting the cell 
view. Now if you open the extracted view you can see the extracted parasitic capacitors. Press “shift+ f” to see 
all the transistors in the extracted view.  

 
Layout-versus-Schematic (LVS) 
 

Why do I get a message that my LVS operation failed?  
 
One of the reasons for LVS to fail is that your schematic might not contain a vdd! and gnd! wire. See the output 
log file for more details.  Also, sometimes these LVS failures can be solved by doing the following: 
 
1) Open your schematic and save it. 
2) Open your layout, save it. Pass DRC, and re-extract it 
3) Open the extracted view and try the LVS once again. 
 
The LVS has succeeded, but my netlists fail to match and I don’t understand why. 
 
Refer to the Guide to Passing LVS.  

 
Analog Simulation 
 

How do I plot signals from nets that are embedded in instances within my schematic? 
 
You must descend to the schematic view of the instance that contains the net you wish to plot. Highlight the 
instance and press “Shift-x” and click “OK”. To return to the top-level schematic, press “b”. 
 
I have made a change to my stimulus file, but the waveform results aren’t changing. 
 
If you make change to a stimulus file after an initial run of a simulation, it may be necessary to recreate the 
netlist. This can be done by choosing from the menu Simulation->Netlist->Create Raw.  You can close the two 
netlist windows that pop up, and re-run the simulation.  
 
I try to run a simulation, but the waveform results do not appear.  
 
There are many reasons this may happen. This may be because: 
 
1) You haven’t selected an analysis for simulation, or any outputs to be plotted 
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2) There are errors in your netlist 
3) You have used a “non-standard” view name (e.g. the view name is “invschematic”). You can check this 

from viewing the cell name in the Library manager. If the view name is not “schematic”, then it needs to be 
renamed.  

4) You made changes to a schematic during simulation, but did not save the schematic. Make sure to save the 
schematic, and then re-run the simulation. 

 
If there are errors in your simulation setup, they are usually reported in the icfb window. Also, it may be 
possible to view these errors by selecting Simulation -> Output Log. Try to address these errors manually if 
possible. 
 
I try to run a simulation, the waveform results appear, but all of the signals are zero volts. 
 
More than likely, your stimulus file is either incorrectly written, incorrectly linked, or missing altogether. Check 
that the copy of the stimulus file you are working on is the same copy that you specified in Affirma Analog 
environment. A quick way to do this is to close any open copy of the stimulus file, from the menu select Setup -
>Stimuli ->Edit Analog. If you enter the name of an existing stimulus file, it should pop in the text editor. 
 
I try to run a simulation, the waveform results appear, the inputs are changing correctly, but the output 
is not transitioning between Vdd and GND. 
 
It is likely that the signal vdd! is not correctly defined. Check your SPICE stimulus file for the line: 
 
Vdd vdd! 0 3 
 
If you change your stimulus file after an initial simulation, recreate the netlist of your design as described above.  
 
I am trying to select an output from my extracted view, but it does not appear as selected in the Analog 
Design Environment when I click on the nets. 
 
Check for the following:  
 
1) Make sure the word “extracted” appears before the word “schematic” in the “Switch View List” of the 

environment options. 
2) Close all extracted views. When you select an output to be plotted, the correct extracted version should 

open automatically. 
 
If this doesn’t help, try the following process: 
 
1) Close the Analog Environment. 
2) Re-extract the layout of the cell. 
3) Try simulation again. 
 
If this doesn’t help, try closing Cadence, re-opening it and running the simulation normally. 
 
I have tried EVERYTHING and my simulations still don’t seem to work. 
 
Here are some obscure issues that may be causing problems. Consider them only if all of the above suggestions 
didn’t work: 
 
1) If there is white space after any component in your SPICE stimulus file, this can sometimes cause 

unexpected simulation results. Delete any extra spaces or tabs after each line. 
2) It is possible that illegal, invisible characters exist between parameter declarations in your stimulus file. 

Wherever you see a space, try to delete it and re-insert it using the spacebar. 
3) Add a carriage return  (press enter) after the last line in the stimulus file. 
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4) Make sure that no two voltage source names are identical in your stimulus file. This includes case 
insensitive matching for SPICE stimulus files. 

5) Make sure that all instances in a schematic point to the correct cells. Often, when making copies of cells, or 
creating multiple cells with the same name existing in different libraries, you can confuse one for the other 
and instance the wrong cell in a schematic. You can determine the cell library and name of an instance by 
selecting and observing its properties by pressing “q”. 

 
Cadence software is not without its quirks. If you have tried just about everything and you still can’t get the 
correct simulation behavior, try closing and re-launching the analog environment. As second resort, close icfb 
and re-launch Cadence.  As a last resort, log off the computer and log back on, or even switch workstations.  
This can sometimes fix errors that are too obscure and difficult to identify manually. 

 
Stimulus Files 
 

How do I add comment line in my SPICE file?  
 
Adding a * in the first column of the stimulus file comments the line. 
 
How do I write stimulus files? How do I specify components in stimulus files? 
 
Refer to the Guide to Writing Stimulus Files. 
 
How do I “short” two pins together in a stimulus file 
 
This is done by declaring a 0V DC voltage source with terminal names matching the two pins that need to be 
shorted. For instance, if you need to short pins A and B together, use the following SPICE code: 
 
Vname A B 0 
 
(Vname can have any unique name, as long as it starts with “V”). 
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